[Mac] change from java 1.5 to 1.6

Original Source
因為最近在試著用JFLAP,而最新版是要搭配Java 1.6才可以執行該.jar檔,但是我們如果去找java執行檔的Version話,通常是1.5的,如下:http://gist.github.com/369355.js


那這樣就不太好了,但是從教學中意外可以發現其實1.6的版本是有安裝在裡面的,只是預設的版本卻是1.6(?),不知道Apple是不是在某次的更新中把Java從1.5更新到1.6但是卻沒改其預設的版本~"~,不過不重要,現在就是要用Symbolic Link的方式去指向真正的Java 1.6執行檔。

下面就是怎樣做到指向的動作了:
http://gist.github.com/369358.js

OK,現在JFLAP終於可以跑了,開心來畫DFA吧…(嘆),我們下次見啦。

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com Logo

您的留言將使用 WordPress.com 帳號。 登出 / 變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 / 變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 / 變更 )

Google+ photo

您的留言將使用 Google+ 帳號。 登出 / 變更 )

連結到 %s